A Frequent Pattern We All Need to Stop: Unnamed Return Values

Posted by

In this post I am going to describe a hard and fast rule that fixes an awful pattern every dev other than me thinks is okay. Worse, they think it’s great programming that makes them a genius. But the behavior is pretty close to maximally bad.

First I’ll post some code we all know isn’t okay:

    public async qsa(cn: string): Promise<IQR> {
        const rci = await this.cacheService.getCityId(cn);
        const gfd = await this.gymDAO.getMultipleGyms(cn);
        const gs = gfd.rows;
        const ac: IQualificationReport = {
            qualified: 0,
            total: 0,
        };
        for (const g of gs) {
            const lll = g.lat - MAX_ACCEPTABLE_LATITUDE_DIFFERENCE;
            const ull = g.lat + MAX_ACCEPTABLE_LATITUDE_DIFFERENCE;
            const lllng = g.long - MAX_ACCEPTABLE_LONGITUDE_DIFFERENCE;
            const ullng = g.long + MAX_ACCEPTABLE_LONGITUDE_DIFFERENCE;
            const ah = await this.housingDAO.markQualified(rci, lll, ull, lllng, ullng);
            ac.qualified = ac.qualified + ah[0];
        }
        const th = await this.housingDAO.countHousingsInCity(rci);
        ac.total = th;
        return ac;
    }

What’s wrong with this code? The author (me in this case) wrote using single letter variables and acronyms. So if I ask you: What’s this code do? The answer is “No idea.” We can’t tell because the naming scheme is purposely void of meaning. And we all know unmeaningful names are bad code.

It’s for that same reason — that unmeaningful code is bad code — that all developers need to make a specific change to start writing code with increased expressiveness, clarity and readability.

The change goes like this:

Always return a named variable.

I see unnamed return values all the time, and it’s a major mistake wherever you go.

We all know that it’s bad practice to write “const x = whatever.” Returning unnamed code is the same thing.

The proper way to inject meaning into your code involves naming a value before returning it. That way (a) other developers understand the meaning of the returned code and (b) the function concludes with something like a concluding statement.

The named return value, ideally, follows logically from the name of the function. But any name will do, so long as it’s descriptive.

Name your return values.

Leave a Reply

Your email address will not be published. Required fields are marked *